aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..af034b8
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python3
+#**************************************************************************
+# Copyright (C) 2019 Thomas "Cakeisalie5" Touhey <thomas@touhey.fr>
+# This file is part of the thembed Python module, which is MIT-licensed.
+#**************************************************************************
+""" Setup script for the thembed Python package and script. """
+
+from setuptools import setup as _setup
+
+kwargs = {}
+
+try:
+ from sphinx.setup_command import BuildDoc as _BuildDoc
+ kwargs['cmdclass'] = {'build_sphinx': _BuildDoc}
+except ImportError:
+ pass
+
+# Actually, most of the project's data is read from the `setup.cfg` file.
+
+_setup(**kwargs)
+
+# End of file.