aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Touhey <thomas@touhey.fr>2021-09-11 21:09:06 +0200
committerThomas Touhey <thomas@touhey.fr>2021-12-31 21:01:37 +0100
commit542a4bcb3ca5fc0c867c07c399dd16e8642f68d9 (patch)
treed6fd255efc366ed7843bf37fba17f8246a52482d /setup.py
parentb3edd31df8c96035d70c0216e444d6dd9951699f (diff)
Reworking thcolor.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py16
1 files changed, 8 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 6bcf1c6..dc73720 100755
--- a/setup.py
+++ b/setup.py
@@ -1,8 +1,8 @@
#!/usr/bin/env python3
-#******************************************************************************
-# Copyright (C) 2019 Thomas "Cakeisalie5" Touhey <thomas@touhey.fr>
-# This file is part of the thcolor Python 3.x module, which is MIT-licensed.
-#******************************************************************************
+# *****************************************************************************
+# Copyright (C) 2019-2022 Thomas "Cakeisalie5" Touhey <thomas@touhey.fr>
+# This file is part of the thcolor Python module, which is MIT-licensed.
+# *****************************************************************************
""" Setup script for the thcolor Python package and script. """
from setuptools import setup as _setup
@@ -10,10 +10,10 @@ from setuptools import setup as _setup
kwargs = {}
try:
- from sphinx.setup_command import BuildDoc as _BuildDoc
- kwargs['cmdclass'] = {'build_sphinx': _BuildDoc}
-except:
- pass
+ from sphinx.setup_command import BuildDoc as _BuildDoc
+ kwargs['cmdclass'] = {'build_sphinx': _BuildDoc}
+except ImportError:
+ pass
# Actually, most of the project's data is read from the `setup.cfg` file.